Clouder mailing list archives

community@goclouder.net

Re: Issue saving "Registry" Container

by
RU3IX PTY LTD
- 05/01/2015 10:20:11
Thanks Yannick, I kind of fixed the code yesterday itself (I was eager to have this tested and up and running :-), however, I've getting the below error when trying to save the Registry Container

 File "/odoo/custom_addons/clouder/clouder_model.py", line 374, in connect
    key_filename=os.path.expanduser(identityfile))
  File "/odoo8-env/bin/../lib/python2.7/posixpath.py", line 261, in expanduser
    if not path.startswith('~'):
AttributeError: 'list' object has no attribute 'startswith'

On Fri, May 1, 2015 at 7:58 PM, Yannick Buron <yannick.buron@gmail.com> wrote:

Hello,

1) Ok so it worked on Mac, that's interesting I didn't though it would work since Clouder make an extensive use of the ssh binary on the system. Good to know.

2) Well ldap isn't used in production yet. I developed it because later I'd like to use it (and CAS) to have a single sign on on all the application hosted by a Clouder, but it's still a far dream for now.
It's not in unfinished directory because I made it works some months ago. I just made a debug https://github.com/clouder-community/clouder/commit/96566df52590b6f97e057a95b3635db4243252fc, you can retest but notice that it's still a very basic installation.


Clouder
Building the tools we need
98 Avenue du general pierre billotte BatD
94000 Creteil
www.goclouder.net | www.wikicompare.info

Le 30/04/2015 11:30, Naran M a écrit :
<blockquote cite="mid:762F709A-88FD-4DA3-A09D-AF0D725F73CD@gmail.com" type="cite">
Hi Yannick - I am having issues saving the Registry container, below are the steps I followed

1) I have created the server entry and all went well , except I need to create a ssh key file ( I installed the Clouder in Mac)

2) Built the version of Registry image and created a new container entry for it, but when I tried to save, below is the error message
File "/odoo/openerp/api.py", line 336, in old_api
    result = method(recs, *args, **kwargs)
  File "/odoo/custom_addons/clouder_template_ldap/clouder_template_ldap.py", line 63, in create
    return super(ClouderContainer, self).create_vals()
AttributeError: 'super' object has no attribute 'create_vals'
Cheers,

Naran

_______________________________________________
Mailing-List: http://www.goclouder.net/groups/clouder-5
Post to: mailto:community@goclouder.net
Unsubscribe: http://www.goclouder.net/groups?unsubscribe


_______________________________________________
Mailing-List: http://www.goclouder.net/groups/clouder-5
Post to: mailto:community@goclouder.net
Unsubscribe: http://www.goclouder.net/groups?unsubscribe